aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59584a93e..95b57e49d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -440,17 +440,17 @@ add_definition_if_function_found(strptime HAVE_STRPTIME)
add_definitions(-DAUTO_INITIALIZE_EASYLOGGINGPP)
# Generate header for embedded translations
-add_subdirectory(translations)
+#add_subdirectory(translations)
#=======
-## Generate header for embedded translations, use target toolchain if depends, otherwise use the
-## lrelease and lupdate binaries from the host
-#include(ExternalProject)
-#ExternalProject_Add(generate_translations_header
-# SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
-# BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
-# STAMP_DIR ${LRELEASE_PATH}
-# CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
-# INSTALL_COMMAND cmake -E echo "")
+# Generate header for embedded translations, use target toolchain if depends, otherwise use the
+# lrelease and lupdate binaries from the host
+include(ExternalProject)
+ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+ CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND cmake -E echo "")
#>>>>>>> b1f43170... Add lrelease to the depends
include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
add_subdirectory(external)