aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5514b221..d421a8774 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -462,9 +462,11 @@ endif()
list(APPEND EXTRA_LIBRARIES ${CMAKE_DL_LIBS})
-if(NOT MINGW AND NOT APPLE)
- find_library(ATOMIC atomic)
- list(APPEND EXTRA_LIBRARIES ${ATOMIC})
+if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
+ if(NOT MINGW AND NOT APPLE)
+ find_library(ATOMIC atomic)
+ list(APPEND EXTRA_LIBRARIES ${ATOMIC})
+ endif()
endif()
include(version.cmake)