aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 3 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f15c73dc..0d82324a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,10 +65,10 @@ else()
set(ARCH_ID "${ARCH}")
endif()
string(TOLOWER "${ARCH_ID}" ARM_ID)
-string(SUBSTRING "${ARCH_ID}" 0 3 ARM_TEST)
+string(SUBSTRING "${ARM_ID}" 0 3 ARM_TEST)
if (ARM_TEST STREQUAL "arm")
set(ARM 1)
- string(SUBSTRING "${ARCH_ID}" 0 5 ARM_TEST)
+ string(SUBSTRING "${ARM_ID}" 0 5 ARM_TEST)
if (ARM_TEST STREQUAL "armv6")
set(ARM6 1)
endif()
@@ -77,7 +77,7 @@ if (ARM_TEST STREQUAL "arm")
endif()
endif()
-if (ARCH_ID STREQUAL "aarch64")
+if (ARM_ID STREQUAL "aarch64")
set(ARM 1)
set(ARM8 1)
endif()
@@ -512,11 +512,6 @@ else()
if(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
# There is a clang bug that does not allow to compile code that uses AES-NI intrinsics if -flto is enabled, so explicitly disable
set(USE_LTO false)
- # explicitly define stdlib for older versions of clang
- if(CMAKE_C_COMPILER_VERSION VERSION_LESS 3.7)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libstdc++")
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -stdlib=libstdc++")
- endif()
endif()