aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c0846280c..45bc12712 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1136,7 +1136,9 @@ if (HIDAPI_FOUND OR LibUSB_COMPILE_TEST_PASSED)
endif()
endif()
-option(USE_READLINE "Build with GNU readline support." ON)
+if(NOT OPENBSD)
+ option(USE_READLINE "Build with GNU readline support." ON)
+endif()
if(USE_READLINE AND NOT DEPENDS)
find_package(Readline)
if(READLINE_FOUND AND GNU_READLINE_FOUND)