aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f59493345..c01be24d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,14 @@ else()
set(OPT_FLAGS_RELEASE "-Ofast")
endif()
+# BUILD_TAG is used to select the build type to check for a new version
+if(BUILD_TAG)
+ message(STATUS "Building build tag ${BUILD_TAG}")
+ add_definitions("-DBUILD_TAG=${BUILD_TAG}")
+else()
+ message(STATUS "Building without build tag")
+endif()
+
set(CMAKE_C_FLAGS_RELEASE "-DNDEBUG ${OPT_FLAGS_RELEASE}")
set(CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG ${OPT_FLAGS_RELEASE}")