aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62db856f4..971c097ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -689,8 +689,16 @@ endif()
include(version.cmake)
+find_path(ZMQ_INCLUDE_PATH zmq.hpp)
find_library(ZMQ_LIB zmq)
+if(NOT ZMQ_INCLUDE_PATH)
+ message(FATAL_ERROR "Could not find required header zmq.hpp")
+endif()
+if(NOT ZMQ_LIB)
+ message(FATAL_ERROR "Could not find require libzmq")
+endif()
+
function (treat_warnings_as_errors dirs)
foreach(dir ${ARGV})
set_property(DIRECTORY ${dir}