aboutsummaryrefslogtreecommitdiff
path: root/tests/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 13:01:56 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commit7bfcffadb91022e420b32a2d0cfa97a0e9f98b64 (patch)
tree63bb4c06e25737e86a3392aab24f625ade7aa900 /tests/unit_tests/CMakeLists.txt
parentcmake: handle private vs. public headers (diff)
downloadmonero-7bfcffadb91022e420b32a2d0cfa97a0e9f98b64.tar.xz
cmake: put each test executable in its own directory
Diffstat (limited to 'tests/unit_tests/CMakeLists.txt')
-rw-r--r--tests/unit_tests/CMakeLists.txt80
1 files changed, 80 insertions, 0 deletions
diff --git a/tests/unit_tests/CMakeLists.txt b/tests/unit_tests/CMakeLists.txt
new file mode 100644
index 000000000..f9ee5919a
--- /dev/null
+++ b/tests/unit_tests/CMakeLists.txt
@@ -0,0 +1,80 @@
+# Copyright (c) 2014, The Monero Project
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification, are
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this list of
+# conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice, this list
+# of conditions and the following disclaimer in the documentation and/or other
+# materials provided with the distribution.
+#
+# 3. Neither the name of the copyright holder nor the names of its contributors may be
+# used to endorse or promote products derived from this software without specific
+# prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set(unit_tests_sources
+ address_from_url.cpp
+ base58.cpp
+ block_reward.cpp
+ chacha8.cpp
+ checkpoints.cpp
+ decompose_amount_into_digits.cpp
+ dns_resolver.cpp
+ epee_boosted_tcp_server.cpp
+ epee_levin_protocol_handler_async.cpp
+ get_xtype_from_string.cpp
+ main.cpp
+ mnemonics.cpp
+ mul_div.cpp
+ parse_amount.cpp
+ serialization.cpp
+ slow_memmem.cpp
+ test_format_utils.cpp
+ test_peerlist.cpp
+ test_protocol_pack.cpp)
+
+set(unit_tests_headers
+ unit_tests_utils.h)
+
+add_executable(unit_tests
+ ${unit_tests_sources}
+ ${unit_tests_headers})
+target_link_libraries(unit_tests
+ PRIVATE
+ cryptonote_core
+ rpc
+ wallet
+ gtest_main
+ ${Boost_CHRONO_LIBRARY}
+ ${Boost_REGEX_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${Boost_THREAD_LIBRARY}
+ ${EXTRA_LIBRARIES})
+set_property(TARGET unit_tests
+ PROPERTY
+ FOLDER "tests")
+
+if (NOT MSVC)
+ set_property(TARGET unit_tests
+ APPEND_STRING
+ PROPERTY
+ COMPILE_FLAGS " -Wno-undef -Wno-sign-compare")
+endif ()
+
+add_test(
+ NAME unit_tests
+ COMMAND unit_tests)