aboutsummaryrefslogtreecommitdiff
path: root/tests/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorjeffro256 <jeffro256@tutanota.com>2023-07-07 12:55:02 -0500
committerjeffro256 <jeffro256@tutanota.com>2023-08-23 11:52:31 -0500
commitba98269ca507766aa76f0ebbcaebe6f6eef93192 (patch)
treee6a63967922b76fca1d11e4a117739a20498292a /tests/unit_tests/CMakeLists.txt
parentMerge pull request #8957 (diff)
downloadmonero-ba98269ca507766aa76f0ebbcaebe6f6eef93192.tar.xz
wallet2: fix `store_to()` and `change_password()`
Resolves #8932 and: 2. Not storing cache when new path is different from old in `store_to()` and 3. Detecting same path when new path contains entire string of old path in `store_to()` and 4. Changing your password / decrypting your keys (in this method or others) and providing a bad original password and getting no error and 5. Changing your password and storing to a new file
Diffstat (limited to 'tests/unit_tests/CMakeLists.txt')
-rw-r--r--tests/unit_tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unit_tests/CMakeLists.txt b/tests/unit_tests/CMakeLists.txt
index 147b38dd4..fec36803e 100644
--- a/tests/unit_tests/CMakeLists.txt
+++ b/tests/unit_tests/CMakeLists.txt
@@ -97,6 +97,7 @@ set(unit_tests_sources
output_selection.cpp
vercmp.cpp
ringdb.cpp
+ wallet_storage.cpp
wipeable_string.cpp
is_hdd.cpp
aligned.cpp