aboutsummaryrefslogtreecommitdiff
path: root/tests/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-10-26 10:16:48 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-11-27 22:15:34 +0000
commit000666ff784185583c76f33bf0882a08fd9c29f2 (patch)
tree47566d1e726380beb28f6823db327f4cb12562ff /tests/unit_tests/CMakeLists.txt
parentMerge pull request #2827 (diff)
downloadmonero-000666ff784185583c76f33bf0882a08fd9c29f2.tar.xz
add a memwipe function
It's meant to avoid being optimized out memory_cleanse lifted from bitcoin
Diffstat (limited to 'tests/unit_tests/CMakeLists.txt')
-rw-r--r--tests/unit_tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/unit_tests/CMakeLists.txt b/tests/unit_tests/CMakeLists.txt
index e10648d20..3aa35aab7 100644
--- a/tests/unit_tests/CMakeLists.txt
+++ b/tests/unit_tests/CMakeLists.txt
@@ -49,6 +49,7 @@ set(unit_tests_sources
hashchain.cpp
http.cpp
main.cpp
+ memwipe.cpp
mnemonics.cpp
mul_div.cpp
parse_amount.cpp
@@ -100,6 +101,8 @@ if (NOT MSVC)
COMPILE_FLAGS " -Wno-undef -Wno-sign-compare")
endif ()
+SET_PROPERTY(SOURCE memwipe.cpp PROPERTY COMPILE_FLAGS -Ofast)
+
add_test(
NAME unit_tests
COMMAND unit_tests --data-dir "${TEST_DATA_DIR}")