aboutsummaryrefslogtreecommitdiff
path: root/tests/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-07-02 22:41:15 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-08-07 09:33:04 +0100
commit5be43fcdbad5ed034b07831473e07f47b7b10947 (patch)
tree260422ebe0f60763ad1d61c610c77805ffa25a72 /tests/unit_tests/CMakeLists.txt
parentMerge pull request #2159 (diff)
downloadmonero-5be43fcdbad5ed034b07831473e07f47b7b10947.tar.xz
cryptonote_protocol_handler: sync speedup
A block queue is now placed between block download and block processing. Blocks are now requested only from one peer (unless starved). Includes a new sync_info coommand.
Diffstat (limited to 'tests/unit_tests/CMakeLists.txt')
-rw-r--r--tests/unit_tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/unit_tests/CMakeLists.txt b/tests/unit_tests/CMakeLists.txt
index da95a97a9..2f62dc2aa 100644
--- a/tests/unit_tests/CMakeLists.txt
+++ b/tests/unit_tests/CMakeLists.txt
@@ -31,6 +31,7 @@ set(unit_tests_sources
ban.cpp
base58.cpp
blockchain_db.cpp
+ block_queue.cpp
block_reward.cpp
canonical_amounts.cpp
chacha8.cpp
@@ -72,6 +73,7 @@ add_executable(unit_tests
target_link_libraries(unit_tests
PRIVATE
ringct
+ cryptonote_protocol
cryptonote_core
blockchain_db
rpc