aboutsummaryrefslogtreecommitdiff
path: root/tests/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-05-15 20:38:27 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-05-15 21:45:34 +0100
commitb88c9a003e2a6643fd41a4eb70fb9b9460b75a97 (patch)
tree35fc7c5c55d1c7bd416fd8dd6750009bef94c4cf /tests/unit_tests/CMakeLists.txt
parentMerge pull request #3775 (diff)
downloadmonero-b88c9a003e2a6643fd41a4eb70fb9b9460b75a97.tar.xz
unit_tests: set default data dir to the source tree at build time
Diffstat (limited to 'tests/unit_tests/CMakeLists.txt')
-rw-r--r--tests/unit_tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/unit_tests/CMakeLists.txt b/tests/unit_tests/CMakeLists.txt
index 9c58536c9..249dbdbe8 100644
--- a/tests/unit_tests/CMakeLists.txt
+++ b/tests/unit_tests/CMakeLists.txt
@@ -103,6 +103,8 @@ if (NOT MSVC)
COMPILE_FLAGS " -Wno-undef -Wno-sign-compare")
endif ()
+SET_PROPERTY(SOURCE main.cpp PROPERTY COMPILE_FLAGS -DDEFAULT_DATA_DIR="\\"${CMAKE_SOURCE_DIR}/tests/data\\"")
+
SET_PROPERTY(SOURCE memwipe.cpp PROPERTY COMPILE_FLAGS -Ofast)
add_test(