aboutsummaryrefslogtreecommitdiff
path: root/tests/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-08-02 11:44:31 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-08-16 11:57:46 +0000
commit70271fa7888f44bb6ec11058853256fc3055037f (patch)
treea85ece632226d073641495533cb1e91d96964920 /tests/unit_tests/CMakeLists.txt
parentstore secret keys encrypted where possible (diff)
downloadmonero-70271fa7888f44bb6ec11058853256fc3055037f.tar.xz
common: add a class to safely wrap mlock/munlock
This class will allow mlocking small objects, of which there may be several per page. It adds refcounting so pages are only munlocked when the last object on that page munlocks.
Diffstat (limited to 'tests/unit_tests/CMakeLists.txt')
-rw-r--r--tests/unit_tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unit_tests/CMakeLists.txt b/tests/unit_tests/CMakeLists.txt
index 6d4ebe47d..4b4870c15 100644
--- a/tests/unit_tests/CMakeLists.txt
+++ b/tests/unit_tests/CMakeLists.txt
@@ -53,6 +53,7 @@ set(unit_tests_sources
http.cpp
main.cpp
memwipe.cpp
+ mlocker.cpp
mnemonics.cpp
mul_div.cpp
multisig.cpp