aboutsummaryrefslogtreecommitdiff
path: root/tests/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2016-03-29 17:56:42 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2016-03-29 17:56:42 +0100
commit34957fcbb97052532b8f16f7cb2bd637904e047b (patch)
tree14a53c0ffb612988f34aaf2953983bcb93cf0d47 /tests/unit_tests/CMakeLists.txt
parentMerge pull request #765 (diff)
downloadmonero-34957fcbb97052532b8f16f7cb2bd637904e047b.tar.xz
tests: add test for needed OpenSSL algorithms in unbound
These can be compiled out of libunbound, leading to failure to check DNSSEC validity.
Diffstat (limited to 'tests/unit_tests/CMakeLists.txt')
-rw-r--r--tests/unit_tests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/unit_tests/CMakeLists.txt b/tests/unit_tests/CMakeLists.txt
index db20bbc2d..2e5100229 100644
--- a/tests/unit_tests/CMakeLists.txt
+++ b/tests/unit_tests/CMakeLists.txt
@@ -49,7 +49,8 @@ set(unit_tests_sources
test_format_utils.cpp
test_peerlist.cpp
test_protocol_pack.cpp
- hardfork.cpp)
+ hardfork.cpp
+ unbound.cpp)
set(unit_tests_headers
unit_tests_utils.h)
@@ -69,6 +70,7 @@ target_link_libraries(unit_tests
${Boost_REGEX_LIBRARY}
${Boost_SYSTEM_LIBRARY}
${Boost_THREAD_LIBRARY}
+ ${UNBOUND_LIBRARIES}
${EXTRA_LIBRARIES})
set_property(TARGET unit_tests
PROPERTY