aboutsummaryrefslogtreecommitdiff
path: root/tests/unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2016-05-14 10:30:11 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2016-08-28 21:27:19 +0100
commit2d6303fb2c2964bb10b3dd58d0e48344753bc2a7 (patch)
treef77ef6555f90571cb8df53480ad2652cd37def51 /tests/unit_tests/CMakeLists.txt
parentringct: import of Shen Noether's ring confidential transactions (diff)
downloadmonero-2d6303fb2c2964bb10b3dd58d0e48344753bc2a7.tar.xz
tests: add Shen Noether's basic ringct tests
Diffstat (limited to '')
-rw-r--r--tests/unit_tests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/unit_tests/CMakeLists.txt b/tests/unit_tests/CMakeLists.txt
index 1b272cf5a..7561aa49d 100644
--- a/tests/unit_tests/CMakeLists.txt
+++ b/tests/unit_tests/CMakeLists.txt
@@ -51,7 +51,8 @@ set(unit_tests_sources
test_protocol_pack.cpp
hardfork.cpp
unbound.cpp
- varint.cpp)
+ varint.cpp
+ ringct.cpp)
set(unit_tests_headers
unit_tests_utils.h)
@@ -61,6 +62,7 @@ add_executable(unit_tests
${unit_tests_headers})
target_link_libraries(unit_tests
LINK_PRIVATE
+ ringct
cryptonote_core
blockchain_db
rpc