aboutsummaryrefslogtreecommitdiff
path: root/tests/trezor/CMakeLists.txt
diff options
context:
space:
mode:
authormj-xmr <mjxmr@protonmail.com>2020-10-26 20:53:21 +0100
committermj-xmr <mjxmr@protonmail.com>2020-10-28 20:08:26 +0100
commit8a282f64c9c99f584d2a1bd06a11ad5651cd2413 (patch)
tree6f145354d796770e5e84ca6b3579b5c1231f7ee3 /tests/trezor/CMakeLists.txt
parentMerge pull request #6902 (diff)
downloadmonero-8a282f64c9c99f584d2a1bd06a11ad5651cd2413.tar.xz
Add RELINK_TARGETS, monero_add_target_no_relink and use monero_add_executable/monero_add_library where possible (mj-xmr)
Add monero_add_minimal_executable and use in tests This is done in order not to have to relink targets, when just an .so changed, but not its interface.
Diffstat (limited to '')
-rw-r--r--tests/trezor/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/trezor/CMakeLists.txt b/tests/trezor/CMakeLists.txt
index 15ed5668d..382d8e46f 100644
--- a/tests/trezor/CMakeLists.txt
+++ b/tests/trezor/CMakeLists.txt
@@ -40,7 +40,7 @@ set(trezor_tests_headers
../core_tests/chaingen.h
../core_tests/wallet_tools.h)
-add_executable(trezor_tests
+monero_add_minimal_executable(trezor_tests
${trezor_tests_sources}
${trezor_tests_headers})