aboutsummaryrefslogtreecommitdiff
path: root/tests/libwallet_api_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorIlya Kitaev <mbg033@gmail.com>2016-02-20 19:04:56 +0300
committerIlya Kitaev <mbg033@gmail.com>2016-03-16 14:27:57 +0300
commit930bed7074c6a54601105bda8f26638ca45e60fd (patch)
tree8c7fff973121add66effcb7554f8095e83225c51 /tests/libwallet_api_tests/CMakeLists.txt
parentwallet2 public api. initial commit (diff)
downloadmonero-930bed7074c6a54601105bda8f26638ca45e60fd.tar.xz
tests for wallet2_api
Diffstat (limited to 'tests/libwallet_api_tests/CMakeLists.txt')
-rw-r--r--tests/libwallet_api_tests/CMakeLists.txt59
1 files changed, 59 insertions, 0 deletions
diff --git a/tests/libwallet_api_tests/CMakeLists.txt b/tests/libwallet_api_tests/CMakeLists.txt
new file mode 100644
index 000000000..e60947084
--- /dev/null
+++ b/tests/libwallet_api_tests/CMakeLists.txt
@@ -0,0 +1,59 @@
+# Copyright (c) 2014-2016, The Monero Project
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification, are
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this list of
+# conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice, this list
+# of conditions and the following disclaimer in the documentation and/or other
+# materials provided with the distribution.
+#
+# 3. Neither the name of the copyright holder nor the names of its contributors may be
+# used to endorse or promote products derived from this software without specific
+# prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set(libwallet_api_tests_sources
+ main.cpp
+)
+
+set(libwallet_api_tests_headers
+ )
+
+add_executable(libwallet_api_tests
+ ${libwallet_api_tests_sources}
+ ${libwallet_api_tests_headers})
+
+target_link_libraries(libwallet_api_tests
+ LINK_PRIVATE
+ wallet
+ ${GTEST_MAIN_LIBRARIES}
+ ${EXTRA_LIBRARIES})
+
+set_property(TARGET libwallet_api_tests
+ PROPERTY
+ FOLDER "tests")
+
+if (NOT MSVC)
+ set_property(TARGET libwallet_api_tests
+ APPEND_STRING
+ PROPERTY
+ COMPILE_FLAGS " -Wno-undef -Wno-sign-compare")
+endif ()
+
+add_test(
+ NAME libwallet_api_tests
+ COMMAND libwallet_api_tests)