aboutsummaryrefslogtreecommitdiff
path: root/tests/hash/CMakeLists.txt
diff options
context:
space:
mode:
authorSChernykh <sergey.v.chernykh@gmail.com>2018-08-03 11:41:41 +0200
committerSChernykh <sergey.v.chernykh@gmail.com>2018-09-09 20:43:01 +0200
commit5fd83c13fbf8dc304909345e60a853c15b0de1e5 (patch)
treec9f33a6fc5ad4b4eb8268afb38c2d81b479e4b3b /tests/hash/CMakeLists.txt
parentMerge pull request #4129 (diff)
downloadmonero-5fd83c13fbf8dc304909345e60a853c15b0de1e5.tar.xz
Cryptonight variant 2
Contains two modifications to improve ASIC resistance: shuffle and integer math. Shuffle makes use of the whole 64-byte cache line instead of 16 bytes only, making Cryptonight 4 times more demanding for memory bandwidth. Integer math adds 64:32 bit integer division followed by 64 bit integer square root, adding large and unavoidable computational latency to the main loop. More details and performance numbers: https://github.com/SChernykh/xmr-stak-cpu/blob/master/README.md
Diffstat (limited to 'tests/hash/CMakeLists.txt')
-rw-r--r--tests/hash/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/hash/CMakeLists.txt b/tests/hash/CMakeLists.txt
index 92abeca20..433cf94e9 100644
--- a/tests/hash/CMakeLists.txt
+++ b/tests/hash/CMakeLists.txt
@@ -43,8 +43,12 @@ set_property(TARGET hash-tests
PROPERTY
FOLDER "tests")
-foreach (hash IN ITEMS fast slow slow-1 tree extra-blake extra-groestl extra-jh extra-skein)
+foreach (hash IN ITEMS fast slow slow-1 slow-2 tree extra-blake extra-groestl extra-jh extra-skein)
add_test(
NAME "hash-${hash}"
COMMAND hash-tests "${hash}" "${CMAKE_CURRENT_SOURCE_DIR}/tests-${hash}.txt")
endforeach ()
+
+add_test(
+ NAME "hash-variant2-int-sqrt"
+ COMMAND hash-tests "variant2_int_sqrt")