aboutsummaryrefslogtreecommitdiff
path: root/tests/hash/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2016-09-18 11:44:08 +0200
committerRiccardo Spagni <ric@spagni.net>2016-09-18 11:44:08 +0200
commit4a03a8a1da1341fcceeb8a73a24ea1b4cedb443c (patch)
treeae9b02dcb8c241b719e0f8ea7c4ef3fe991b9f3a /tests/hash/CMakeLists.txt
parentMerge pull request #1093 (diff)
parentcmake: support BUILD_SHARED_LIBS built-in option (diff)
downloadmonero-4a03a8a1da1341fcceeb8a73a24ea1b4cedb443c.tar.xz
Merge pull request #1094
06bb692 cmake: support BUILD_SHARED_LIBS built-in option (redfish) e1c7af3 cmake: transitive deps and remove deprecated LINK_* (redfish) 54010b9 crypto: armv7: slow-hash: remove redundant source include (redfish)
Diffstat (limited to 'tests/hash/CMakeLists.txt')
-rw-r--r--tests/hash/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/hash/CMakeLists.txt b/tests/hash/CMakeLists.txt
index 426ecf6bf..7f79ee939 100644
--- a/tests/hash/CMakeLists.txt
+++ b/tests/hash/CMakeLists.txt
@@ -35,8 +35,9 @@ add_executable(hash-tests
${hash_sources}
${hash_headers})
target_link_libraries(hash-tests
- LINK_PRIVATE
- crypto)
+ PRIVATE
+ crypto
+ ${EXTRA_LIBRARIES})
set_property(TARGET hash-tests
PROPERTY
FOLDER "tests")