aboutsummaryrefslogtreecommitdiff
path: root/tests/hash/CMakeLists.txt
diff options
context:
space:
mode:
authorSChernykh <sergey.v.chernykh@gmail.com>2019-02-04 17:49:19 +0100
committerSChernykh <sergey.v.chernykh@gmail.com>2019-02-14 11:29:54 +0100
commitf51397b3064da60891b7e982d040b7715bbbf59a (patch)
treec5bab9cc390094b386c94dd3436e8f1bd38e92e4 /tests/hash/CMakeLists.txt
parentMerge pull request #4988 (diff)
downloadmonero-f51397b3064da60891b7e982d040b7715bbbf59a.tar.xz
Cryptonight variant 4 aka CryptonightR
It introduces random integer math into the main loop.
Diffstat (limited to 'tests/hash/CMakeLists.txt')
-rw-r--r--tests/hash/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/hash/CMakeLists.txt b/tests/hash/CMakeLists.txt
index 433cf94e9..105cf2c13 100644
--- a/tests/hash/CMakeLists.txt
+++ b/tests/hash/CMakeLists.txt
@@ -43,7 +43,7 @@ set_property(TARGET hash-tests
PROPERTY
FOLDER "tests")
-foreach (hash IN ITEMS fast slow slow-1 slow-2 tree extra-blake extra-groestl extra-jh extra-skein)
+foreach (hash IN ITEMS fast slow slow-1 slow-2 slow-4 tree extra-blake extra-groestl extra-jh extra-skein)
add_test(
NAME "hash-${hash}"
COMMAND hash-tests "${hash}" "${CMAKE_CURRENT_SOURCE_DIR}/tests-${hash}.txt")