aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2020-12-14 14:25:44 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2020-12-14 19:40:24 +0000
commit0660db3e7a0f561ecd70c0cecc3bbf267534021b (patch)
treef5cb7b152873e4be76dcc898a3f9f6238d055431 /tests/fuzz/CMakeLists.txt
parentMerge pull request #7102 (diff)
downloadmonero-0660db3e7a0f561ecd70c0cecc3bbf267534021b.tar.xz
fuzz_tests: add a test for utf8canonical
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index a599f86f8..0cf1740ad 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -218,3 +218,13 @@ set_property(TARGET tx-extra_fuzz_tests
PROPERTY
FOLDER "tests")
+monero_add_minimal_executable(utf8_fuzz_tests utf8.cpp fuzzer.cpp)
+target_link_libraries(utf8_fuzz_tests
+ PRIVATE
+ common
+ epee
+ ${Boost_THREAD_LIBRARY}
+ ${Boost_CHRONO_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES}
+ $ENV{LIB_FUZZING_ENGINE})