aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-11 09:33:01 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-23 11:29:52 +0000
commitf1bdc9a42a7d75f90cc0c1e4191f4ef1a016a11a (patch)
tree7867b606420df406a44c4ca5fa0852ecf44a1e83 /tests/fuzz/CMakeLists.txt
parentadd parse_url fuzz test (diff)
downloadmonero-f1bdc9a42a7d75f90cc0c1e4191f4ef1a016a11a.tar.xz
tests: add http client fuzz test
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index 8090b465a..2184ae48a 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -138,3 +138,17 @@ set_property(TARGET parse-url_fuzz_tests
PROPERTY
FOLDER "tests")
+add_executable(http-client_fuzz_tests http-client.cpp fuzzer.cpp)
+target_link_libraries(http-client_fuzz_tests
+ PRIVATE
+ epee
+ ${Boost_THREAD_LIBRARY}
+ ${Boost_REGEX_LIBRARY}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+set_property(TARGET http-client_fuzz_tests
+ PROPERTY
+ FOLDER "tests")
+