aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-10 15:52:24 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-23 11:27:45 +0000
commit261b0dd0e041e9e1fd5370cf5fca44ae2d84123e (patch)
tree63448e78d698d355b69324150a3cac3319d94ca2 /tests/fuzz/CMakeLists.txt
parentfuzz_testing: allow automatically resuming an interrupted job (diff)
downloadmonero-261b0dd0e041e9e1fd5370cf5fca44ae2d84123e.tar.xz
tests: add base58 fuzz test
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index 01c17359c..5b1cef182 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -113,3 +113,15 @@ set_property(TARGET load-from-json_fuzz_tests
PROPERTY
FOLDER "tests")
+add_executable(base58_fuzz_tests base58.cpp fuzzer.cpp)
+target_link_libraries(base58_fuzz_tests
+ PRIVATE
+ common
+ epee
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+set_property(TARGET base58_fuzz_tests
+ PROPERTY
+ FOLDER "tests")
+