aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2017-08-26 23:43:09 +0200
committerRiccardo Spagni <ric@spagni.net>2017-08-26 23:43:09 +0200
commitff0afc196e2dbbea2c6296f93314267045948362 (patch)
tree253489e690565ff9c63d0fe5d09d0541a9ec3714 /tests/fuzz/CMakeLists.txt
parentMerge pull request #2353 (diff)
parentCleanup test impact of moving blockchain_db_types() (diff)
downloadmonero-ff0afc196e2dbbea2c6296f93314267045948362.tar.xz
Merge pull request #2313
3dd34a49 Cleanup test impact of moving blockchain_db_types() (Howard Chu) 80344740 More DB support cleanup (Howard Chu) 4c7f8ac0 DB cleanup (Howard Chu)
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index 853d46a12..cb77f8f56 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -30,6 +30,8 @@ add_executable(block_fuzz_tests block.cpp fuzzer.cpp)
target_link_libraries(block_fuzz_tests
PRIVATE
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}
@@ -42,6 +44,8 @@ add_executable(transaction_fuzz_tests transaction.cpp fuzzer.cpp)
target_link_libraries(transaction_fuzz_tests
PRIVATE
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}
@@ -55,6 +59,8 @@ target_link_libraries(signature_fuzz_tests
PRIVATE
wallet
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}
@@ -68,6 +74,8 @@ target_link_libraries(cold-outputs_fuzz_tests
PRIVATE
wallet
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}
@@ -81,6 +89,8 @@ target_link_libraries(cold-transaction_fuzz_tests
PRIVATE
wallet
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}