aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-11 18:32:40 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-23 11:29:55 +0000
commitec724eb64ab4fc5dcc518efc606d630ebc89f119 (patch)
tree1625d8c5ebb11129c3a7ee6ce5da6cd0cf2ceb38 /tests/fuzz/CMakeLists.txt
parenttests: add http client fuzz test (diff)
downloadmonero-ec724eb64ab4fc5dcc518efc606d630ebc89f119.tar.xz
tests: add levin fuzz test
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index 2184ae48a..5d58f9a3c 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -152,3 +152,17 @@ set_property(TARGET http-client_fuzz_tests
PROPERTY
FOLDER "tests")
+add_executable(levin_fuzz_tests levin.cpp fuzzer.cpp)
+target_link_libraries(levin_fuzz_tests
+ PRIVATE
+ common
+ epee
+ ${Boost_THREAD_LIBRARY}
+ ${Boost_REGEX_LIBRARY}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+set_property(TARGET levin_fuzz_tests
+ PROPERTY
+ FOLDER "tests")
+