aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-10 20:17:16 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-23 11:29:49 +0000
commit0272df9e614d472973fbcbdb50591d2dcd8eb10c (patch)
tree4b8ad4ab5fbba70e5d468e93146c848cd2ed0a20 /tests/fuzz/CMakeLists.txt
parenttests: add base58 fuzz test (diff)
downloadmonero-0272df9e614d472973fbcbdb50591d2dcd8eb10c.tar.xz
add parse_url fuzz test
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index 5b1cef182..8090b465a 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -125,3 +125,16 @@ set_property(TARGET base58_fuzz_tests
PROPERTY
FOLDER "tests")
+add_executable(parse-url_fuzz_tests parse_url.cpp fuzzer.cpp)
+target_link_libraries(parse-url_fuzz_tests
+ PRIVATE
+ epee
+ ${Boost_REGEX_LIBRARY}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+set_property(TARGET parse-url_fuzz_tests
+ PROPERTY
+ FOLDER "tests")
+