aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
authorHoward Chu <hyc@symas.com>2017-08-22 15:10:40 +0100
committerHoward Chu <hyc@symas.com>2017-08-22 15:11:28 +0100
commit3dd34a49efd2954b0a5eb020abd168d9379b98c4 (patch)
tree86c6313417bb6e05848bec76d4a11a67d4baad54 /tests/fuzz/CMakeLists.txt
parentMore DB support cleanup (diff)
downloadmonero-3dd34a49efd2954b0a5eb020abd168d9379b98c4.tar.xz
Cleanup test impact of moving blockchain_db_types()
Diffstat (limited to '')
-rw-r--r--tests/fuzz/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index 853d46a12..cb77f8f56 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -30,6 +30,8 @@ add_executable(block_fuzz_tests block.cpp fuzzer.cpp)
target_link_libraries(block_fuzz_tests
PRIVATE
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}
@@ -42,6 +44,8 @@ add_executable(transaction_fuzz_tests transaction.cpp fuzzer.cpp)
target_link_libraries(transaction_fuzz_tests
PRIVATE
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}
@@ -55,6 +59,8 @@ target_link_libraries(signature_fuzz_tests
PRIVATE
wallet
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}
@@ -68,6 +74,8 @@ target_link_libraries(cold-outputs_fuzz_tests
PRIVATE
wallet
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}
@@ -81,6 +89,8 @@ target_link_libraries(cold-transaction_fuzz_tests
PRIVATE
wallet
cryptonote_core
+ common
+ blockchain_db
p2p
epee
${CMAKE_THREAD_LIBS_INIT}