aboutsummaryrefslogtreecommitdiff
path: root/tests/functional_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-03-15 15:15:28 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-03-21 19:27:42 +0000
commitef7681b6991e45b4d1dc2e0831442fff3443ba55 (patch)
tree443d2ab5299ceaeec637ff686117aa0a7d596074 /tests/functional_tests/CMakeLists.txt
parentfunctional_tests: add basic mining tests (diff)
downloadmonero-ef7681b6991e45b4d1dc2e0831442fff3443ba55.tar.xz
functional_tests: plug RPC tests into the cmake machinery
Diffstat (limited to 'tests/functional_tests/CMakeLists.txt')
-rw-r--r--tests/functional_tests/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/tests/functional_tests/CMakeLists.txt b/tests/functional_tests/CMakeLists.txt
index 2e3519994..60060f56f 100644
--- a/tests/functional_tests/CMakeLists.txt
+++ b/tests/functional_tests/CMakeLists.txt
@@ -49,6 +49,7 @@ target_link_libraries(functional_tests
${Boost_PROGRAM_OPTIONS_LIBRARY}
${CMAKE_THREAD_LIBS_INIT}
${EXTRA_LIBRARIES})
-set_property(TARGET functional_tests
- PROPERTY
- FOLDER "tests")
+
+add_test(
+ NAME functional_tests_rpc
+ COMMAND ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/functional_tests_rpc.py" "${PYTHON_EXECUTABLE}" "${CMAKE_CURRENT_SOURCE_DIR}" "${CMAKE_BINARY_DIR}" all)