aboutsummaryrefslogtreecommitdiff
path: root/tests/functional_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormj-xmr <mjxmr@protonmail.com>2021-02-18 23:30:41 +0100
committermj-xmr <mjxmr@protonmail.com>2021-03-30 05:48:55 +0200
commit45f01f577c108f1890bb3c18e4e1fbf27e0f832d (patch)
tree0b2046c5f15664e2694661bf373e020fe73802e8 /tests/functional_tests/CMakeLists.txt
parentMerge pull request #7476 (diff)
downloadmonero-45f01f577c108f1890bb3c18e4e1fbf27e0f832d.tar.xz
[CI] Adaptive mining timeout, depending on available CPU power
Printing also available RAM. Add comprehensive description.
Diffstat (limited to 'tests/functional_tests/CMakeLists.txt')
-rw-r--r--tests/functional_tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/functional_tests/CMakeLists.txt b/tests/functional_tests/CMakeLists.txt
index 9f7024e36..337097a34 100644
--- a/tests/functional_tests/CMakeLists.txt
+++ b/tests/functional_tests/CMakeLists.txt
@@ -64,6 +64,7 @@ target_link_libraries(make_test_signature
${CMAKE_THREAD_LIBS_INIT}
${EXTRA_LIBRARIES})
+monero_add_minimal_executable(cpu_power_test cpu_power_test.cpp)
find_program(PYTHON3_FOUND python3 REQUIRED)
execute_process(COMMAND ${PYTHON3_FOUND} "-c" "import requests; import psutil; import monotonic; print('OK')" OUTPUT_VARIABLE REQUESTS_OUTPUT OUTPUT_STRIP_TRAILING_WHITESPACE)