aboutsummaryrefslogtreecommitdiff
path: root/tests/functional_tests/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-05-24 21:56:04 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-09-17 11:38:30 +0000
commite037ecb014858054670ef2b0992ba7a934c84e15 (patch)
tree6309fd812859884258ec82ef08703acea096ddc3 /tests/functional_tests/CMakeLists.txt
parentfunctional_tests: add get_transaction_pool_stats (diff)
downloadmonero-e037ecb014858054670ef2b0992ba7a934c84e15.tar.xz
functional_tests: check for RPC methods which aren't exposed
Diffstat (limited to 'tests/functional_tests/CMakeLists.txt')
-rw-r--r--tests/functional_tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/functional_tests/CMakeLists.txt b/tests/functional_tests/CMakeLists.txt
index fd49ba623..bc55da9e3 100644
--- a/tests/functional_tests/CMakeLists.txt
+++ b/tests/functional_tests/CMakeLists.txt
@@ -59,3 +59,7 @@ else()
message(WARNING "functional_tests_rpc skipped, needs the 'requests' python module")
set(CTEST_CUSTOM_TESTS_IGNORE ${CTEST_CUSTOM_TESTS_IGNORE} functional_tests_rpc)
endif()
+
+add_test(
+ NAME check_missing_rpc_methods
+ COMMAND ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/check_missing_rpc_methods.py" "${CMAKE_SOURCE_DIR}")