aboutsummaryrefslogtreecommitdiff
path: root/tests/crypto/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-02-17 12:01:04 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-03-04 11:56:55 +0000
commit0de14396b9adf8fce0b6283c6a24500c514fd0a0 (patch)
tree1b5cd2a1eed04cff5a24f9694305762ad6e6af6a /tests/crypto/CMakeLists.txt
parentcrypto: plug CNv4 JIT into cn_slow_hash (diff)
downloadmonero-0de14396b9adf8fce0b6283c6a24500c514fd0a0.tar.xz
tests: add a CNv4 JIT test
Diffstat (limited to 'tests/crypto/CMakeLists.txt')
-rw-r--r--tests/crypto/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/crypto/CMakeLists.txt b/tests/crypto/CMakeLists.txt
index df96c57cc..8789cb552 100644
--- a/tests/crypto/CMakeLists.txt
+++ b/tests/crypto/CMakeLists.txt
@@ -52,3 +52,17 @@ set_property(TARGET cncrypto-tests
add_test(
NAME cncrypto
COMMAND cncrypto-tests "${CMAKE_CURRENT_SOURCE_DIR}/tests.txt")
+
+add_executable(cnv4-jit-tests cnv4-jit.c)
+target_link_libraries(cnv4-jit-tests
+ PRIVATE
+ crypto
+ common
+ ${EXTRA_LIBRARIES})
+set_property(TARGET cnv4-jit-tests
+ PROPERTY
+ FOLDER "tests")
+
+add_test(
+ NAME cnv4-jit
+ COMMAND cnv4-jit-tests 1788000 1789000)