aboutsummaryrefslogtreecommitdiff
path: root/tests/crypto/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-02-17 12:01:04 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-02-18 13:14:15 +0000
commit993a1994fa5dc9d25391c483218b00010e6bf4ea (patch)
tree366b856ca7766d08b918e73f6eef741bdeb2a9df /tests/crypto/CMakeLists.txt
parentcrypto: plug CNv4 JIT into cn_slow_hash (diff)
downloadmonero-993a1994fa5dc9d25391c483218b00010e6bf4ea.tar.xz
tests: add a CNv4 JIT test
Diffstat (limited to 'tests/crypto/CMakeLists.txt')
-rw-r--r--tests/crypto/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/crypto/CMakeLists.txt b/tests/crypto/CMakeLists.txt
index df96c57cc..8789cb552 100644
--- a/tests/crypto/CMakeLists.txt
+++ b/tests/crypto/CMakeLists.txt
@@ -52,3 +52,17 @@ set_property(TARGET cncrypto-tests
add_test(
NAME cncrypto
COMMAND cncrypto-tests "${CMAKE_CURRENT_SOURCE_DIR}/tests.txt")
+
+add_executable(cnv4-jit-tests cnv4-jit.c)
+target_link_libraries(cnv4-jit-tests
+ PRIVATE
+ crypto
+ common
+ ${EXTRA_LIBRARIES})
+set_property(TARGET cnv4-jit-tests
+ PROPERTY
+ FOLDER "tests")
+
+add_test(
+ NAME cnv4-jit
+ COMMAND cnv4-jit-tests 1788000 1789000)