aboutsummaryrefslogtreecommitdiff
path: root/tests/crypto/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2018-03-14 16:04:10 +0200
committerRiccardo Spagni <ric@spagni.net>2018-03-14 16:04:10 +0200
commit102a51bcd48a3cd2cb794aab7dbe243393f155b3 (patch)
tree513aa5706a9ee849adab2f7cbe719de6741a8b43 /tests/crypto/CMakeLists.txt
parentMerge pull request #3378 (diff)
parentwallet2: check_tx_key() shouldn't require hardware encryption (diff)
downloadmonero-102a51bcd48a3cd2cb794aab7dbe243393f155b3.tar.xz
Merge pull request #3350
4405e4fc wallet2: check_tx_key() shouldn't require hardware encryption (stoffu) 7dfa5e9e chacha: call prehashed version explicitly as generate_chacha_key_prehashed hash: add prehashed version cn_slow_hash_prehashed slow-hash: let cn_slow_hash take 4th parameter for deciding prehashed or not slow-hash: add support for prehashed version for the other 3 platforms (stoffu) b2d23b18 crypto: revert odd namespace changes made in #3303 (stoffu) 8705beaf keypair::generate: always require hw::device to avoid possible mistake (stoffu) 27a196b1 device: untangle cyclic depenency (stoffu) c9b38b47 device: made function prototypes consistent with pre-#3303 codebase (stoffu)
Diffstat (limited to 'tests/crypto/CMakeLists.txt')
-rw-r--r--tests/crypto/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/tests/crypto/CMakeLists.txt b/tests/crypto/CMakeLists.txt
index c89049d50..df96c57cc 100644
--- a/tests/crypto/CMakeLists.txt
+++ b/tests/crypto/CMakeLists.txt
@@ -42,10 +42,7 @@ add_executable(cncrypto-tests
${crypto_headers})
target_link_libraries(cncrypto-tests
PRIVATE
- wallet
- cryptonote_core
common
- device
${Boost_SYSTEM_LIBRARY}
${EXTRA_LIBRARIES})
set_property(TARGET cncrypto-tests