aboutsummaryrefslogtreecommitdiff
path: root/tests/crypto/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-09-17 13:59:29 -0400
committerredfish <redfish@galactica.pw>2016-09-18 02:56:26 -0400
commite1c7af35d47c6f54628418f67128074c1bcd4858 (patch)
tree70bc29dbab48ac5e7d6c1b51dbbe0974704e7214 /tests/crypto/CMakeLists.txt
parentcrypto: armv7: slow-hash: remove redundant source include (diff)
downloadmonero-e1c7af35d47c6f54628418f67128074c1bcd4858.tar.xz
cmake: transitive deps and remove deprecated LINK_*
Keep the immediate direct deps at the library that depends on them, declare deps as PUBLIC so that targets that link against that library get the library's deps as transitive deps. Break dep cycle between blockchain_db <-> crytonote_core. No code refactoring, just hide cycle from cmake so that it doesn't complain (cycles are allowed only between static libs, not shared libs). This is in preparation for supproting BUILD_SHARED_LIBS cmake built-in option for building internal libs as shared.
Diffstat (limited to '')
-rw-r--r--tests/crypto/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/crypto/CMakeLists.txt b/tests/crypto/CMakeLists.txt
index 86946aa5c..9c59cd79e 100644
--- a/tests/crypto/CMakeLists.txt
+++ b/tests/crypto/CMakeLists.txt
@@ -41,7 +41,9 @@ add_executable(crypto-tests
${crypto_sources}
${crypto_headers})
target_link_libraries(crypto-tests
- ${Boost_SYSTEM_LIBRARY})
+ PRIVATE
+ ${Boost_SYSTEM_LIBRARY}
+ ${EXTRA_LIBRARIES})
set_property(TARGET crypto-tests
PROPERTY
FOLDER "tests")