aboutsummaryrefslogtreecommitdiff
path: root/tests/crypto/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 13:01:56 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commit7bfcffadb91022e420b32a2d0cfa97a0e9f98b64 (patch)
tree63bb4c06e25737e86a3392aab24f625ade7aa900 /tests/crypto/CMakeLists.txt
parentcmake: handle private vs. public headers (diff)
downloadmonero-7bfcffadb91022e420b32a2d0cfa97a0e9f98b64.tar.xz
cmake: put each test executable in its own directory
Diffstat (limited to '')
-rw-r--r--tests/crypto/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/tests/crypto/CMakeLists.txt b/tests/crypto/CMakeLists.txt
new file mode 100644
index 000000000..83982eda1
--- /dev/null
+++ b/tests/crypto/CMakeLists.txt
@@ -0,0 +1,50 @@
+# Copyright (c) 2014, The Monero Project
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification, are
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this list of
+# conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice, this list
+# of conditions and the following disclaimer in the documentation and/or other
+# materials provided with the distribution.
+#
+# 3. Neither the name of the copyright holder nor the names of its contributors may be
+# used to endorse or promote products derived from this software without specific
+# prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set(crypto_sources
+ crypto-ops-data.c
+ crypto-ops.c
+ crypto.cpp
+ hash.c
+ main.cpp
+ random.c)
+
+set(crypto_headers
+ crypto-tests.h)
+
+add_executable(crypto-tests
+ ${crypto_sources}
+ ${crypto_headers})
+target_link_libraries(crypto-tests)
+set_property(TARGET crypto-tests
+ PROPERTY
+ FOLDER "tests")
+
+add_test(
+ NAME crypto
+ COMMAND crypto-tests "${CMAKE_CURRENT_SOURCE_DIR}/tests.txt")