aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorjeffro256 <jeffro256@tutanota.com>2023-07-07 12:55:02 -0500
committerjeffro256 <jeffro256@tutanota.com>2023-08-23 11:52:31 -0500
commitba98269ca507766aa76f0ebbcaebe6f6eef93192 (patch)
treee6a63967922b76fca1d11e4a117739a20498292a /tests/CMakeLists.txt
parentMerge pull request #8957 (diff)
downloadmonero-ba98269ca507766aa76f0ebbcaebe6f6eef93192.tar.xz
wallet2: fix `store_to()` and `change_password()`
Resolves #8932 and: 2. Not storing cache when new path is different from old in `store_to()` and 3. Detecting same path when new path contains entire string of old path in `store_to()` and 4. Changing your password / decrypting your keys (in this method or others) and providing a bad original password and getting no error and 5. Changing your password and storing to a new file
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 2cabb1ba5..e074ceed6 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -72,14 +72,8 @@ else ()
include_directories(SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/gtest/include")
endif (GTest_FOUND)
-file(COPY
- data/wallet_9svHk1.keys
- data/wallet_9svHk1
- data/outputs
- data/unsigned_monero_tx
- data/signed_monero_tx
- data/sha256sum
- DESTINATION data)
+message(STATUS "Copying test data directory...")
+file(COPY data DESTINATION .) # Copy data directory from source root to build root
if (CMAKE_BUILD_TYPE STREQUAL "fuzz" OR OSSFUZZ)
add_subdirectory(fuzz)