aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-24 14:48:14 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-24 15:29:51 -0400
commit7d708e422397fb0ba8ac29855eb27964115e7217 (patch)
tree4bc144c393ff8c14d2a6bd443668088f4db5a189 /tests/CMakeLists.txt
parentcmake: fix up miniupnpc's define (diff)
downloadmonero-7d708e422397fb0ba8ac29855eb27964115e7217.tar.xz
cmake: support 2.8.7
Older versions of CMake support LINK_{PUBLIC,PRIVATE} while newer versions prefer PUBLIC and PRIVATE instead, but still support the LINK_ prefix.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 0f99cab73..ae20b8754 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -75,7 +75,7 @@ add_executable(hash-target-tests
${hash_targets_sources}
${hash_targets_headers})
target_link_libraries(hash-target-tests
- PRIVATE
+ LINK_PRIVATE
cryptonote_core)
set_property(TARGET hash-target-tests
PROPERTY