aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:34:42 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:43:00 -0400
commit464c2805e5512117970974d5cadc4e59eee5d921 (patch)
treefb796a5240f6db8aef46abcda61baa91d2411195 /tests/CMakeLists.txt
parentcmake: clean up EXTRA_LIBRARIES (diff)
downloadmonero-464c2805e5512117970974d5cadc4e59eee5d921.tar.xz
cmake: fix up miniupnpc's define
It's only necessary on Windows builds and new versions renamed the define without any compatibility bridge.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 3da9fdb6b..0f99cab73 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -28,9 +28,11 @@
#
# Parts of this file are originally copyright (c) 2012-2013 The Cryptonote developers
-add_definitions(-DSTATICLIB)
-# miniupnp changed their static define
-add_definitions(-DMINIUPNP_STATICLIB)
+if (WIN32 AND STATIC)
+ add_definitions(-DSTATICLIB)
+ # miniupnp changed their static define
+ add_definitions(-DMINIUPNP_STATICLIB)
+endif ()
find_package(GTest)