aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAntonio Juarez <antonio.maria.juarez@live.com>2014-03-03 22:07:58 +0000
committerAntonio Juarez <antonio.maria.juarez@live.com>2014-03-03 22:07:58 +0000
commit296ae46ed8f8f6e5f986f978febad302e3df231a (patch)
tree1629164454a239308f33c9e12afb22e7f3cd8eeb /tests/CMakeLists.txt
parentchanged name (diff)
downloadmonero-296ae46ed8f8f6e5f986f978febad302e3df231a.tar.xz
moved all stuff to github
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt64
1 files changed, 64 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 000000000..64dde411c
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,64 @@
+add_subdirectory(gtest)
+include_directories(${gtest_SOURCE_DIR}/include ${gtest_SOURCE_DIR})
+
+file(GLOB_RECURSE CORE_TESTS core_tests/*)
+file(GLOB_RECURSE CRYPTO_TESTS crypto/*)
+file(GLOB_RECURSE FUNC_TESTS functional_tests/*)
+file(GLOB_RECURSE PERFORMANCE_TESTS performance_tests/*)
+file(GLOB_RECURSE CORE_PROXY core_proxy/*)
+file(GLOB_RECURSE UNIT_TESTS unit_tests/*)
+
+source_group(core_tests FILES ${CORE_TESTS})
+source_group(crypto_tests FILES ${CRYPTO_TESTS})
+source_group(functional_tests FILES ${FUNC_TESTS})
+source_group(performance_tests FILES ${PERFORMANCE_TESTS})
+source_group(core_proxy FILES ${CORE_PROXY})
+source_group(unit_tests FILES ${UNIT_TESTS})
+
+# add_subdirectory(daemon_tests)
+
+add_executable(coretests ${CORE_TESTS})
+add_executable(crypto-tests ${CRYPTO_TESTS})
+add_executable(difficulty-tests difficulty/difficulty.cpp)
+add_executable(hash-tests hash/main.cpp)
+add_executable(hash-target-tests hash-target.cpp)
+add_executable(functional_tests ${FUNC_TESTS})
+add_executable(performance_tests ${PERFORMANCE_TESTS})
+add_executable(core_proxy ${CORE_PROXY})
+add_executable(unit_tests ${UNIT_TESTS})
+add_executable(net_load_tests_clt net_load_tests/clt.cpp)
+add_executable(net_load_tests_srv net_load_tests/srv.cpp)
+
+target_link_libraries(core_proxy cryptonote_core common crypto ${Boost_LIBRARIES})
+target_link_libraries(coretests cryptonote_core common crypto ${Boost_LIBRARIES})
+target_link_libraries(difficulty-tests cryptonote_core)
+target_link_libraries(functional_tests cryptonote_core wallet common crypto ${Boost_LIBRARIES})
+target_link_libraries(hash-tests crypto)
+target_link_libraries(hash-target-tests crypto cryptonote_core)
+target_link_libraries(performance_tests cryptonote_core common crypto ${Boost_LIBRARIES})
+target_link_libraries(unit_tests cryptonote_core common crypto gtest_main ${Boost_LIBRARIES})
+target_link_libraries(net_load_tests_clt cryptonote_core common crypto gtest_main ${Boost_LIBRARIES})
+target_link_libraries(net_load_tests_srv cryptonote_core common crypto gtest_main ${Boost_LIBRARIES})
+
+if(NOT WIN32)
+ target_link_libraries(coretests rt)
+ target_link_libraries(functional_tests rt)
+ target_link_libraries(performance_tests rt)
+ target_link_libraries(core_proxy rt)
+ target_link_libraries(unit_tests rt)
+endif()
+if(NOT MSVC)
+ set_property(TARGET gtest gtest_main unit_tests net_load_tests_clt net_load_tests_srv APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-sign-compare")
+endif()
+
+add_custom_target(tests DEPENDS coretests difficulty hash performance_tests core_proxy unit_tests)
+set_property(TARGET coretests crypto-tests functional_tests difficulty-tests gtest gtest_main hash-tests hash-target-tests performance_tests core_proxy unit_tests tests net_load_tests_clt net_load_tests_srv PROPERTY FOLDER "tests")
+
+add_test(coretests coretests --generate_and_play_test_data)
+add_test(crypto crypto-tests ${CMAKE_CURRENT_SOURCE_DIR}/crypto/tests.txt)
+add_test(difficulty difficulty-tests ${CMAKE_CURRENT_SOURCE_DIR}/difficulty/data.txt)
+foreach(hash IN ITEMS fast slow tree)# extra-blake extra-groestl extra-jh extra-skein)
+add_test(hash-${hash} hash-tests ${hash} ${CMAKE_CURRENT_SOURCE_DIR}/hash/tests-${hash}.txt)
+endforeach(hash)
+add_test(hash-target hash-target-tests)
+add_test(unit_tests unit_tests) \ No newline at end of file