aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2017-09-25 02:46:14 +0000
committerredfish <redfish@galactica.pw>2017-09-28 01:41:44 -0400
commit540d6fa3d5757e30bc251cbe9f2474e67c0a5d74 (patch)
tree83baac57511623349caccfb636d1ffcd536e25b6 /tests/CMakeLists.txt
parentMerge pull request #2496 (diff)
downloadmonero-540d6fa3d5757e30bc251cbe9f2474e67c0a5d74.tar.xz
tests: pass data dir as arg
This fixes test failure on builds that happen to be built in 'build/' instead of 'build/release'. Use boost filesystem path type.
Diffstat (limited to '')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 85763f8b5..a5f5335db 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -30,6 +30,7 @@
# The docs say this only affects grouping in IDEs
set(folder "tests")
+set(TEST_DATA_DIR "${CMAKE_CURRENT_LIST_DIR}/data")
if (WIN32 AND STATIC)
add_definitions(-DSTATICLIB)