aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/api/CMakeLists.txt
diff options
context:
space:
mode:
authoranon <anon [at] nowhere>2021-04-27 12:06:42 +0000
committerselsta <selsta@sent.at>2021-07-13 08:00:20 +0200
commitfe76d7dee7c8ddd7bb6d32cfc7aeedda9d84572e (patch)
treef3eb43648ff242c00842dcba516aa2c5c43fcabc /src/wallet/api/CMakeLists.txt
parentcmake: forbid undefined symbols (diff)
downloadmonero-fe76d7dee7c8ddd7bb6d32cfc7aeedda9d84572e.tar.xz
cmake: fix undefined symbols and multiple definitions
Diffstat (limited to 'src/wallet/api/CMakeLists.txt')
-rw-r--r--src/wallet/api/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/wallet/api/CMakeLists.txt b/src/wallet/api/CMakeLists.txt
index 30eb4ce03..655cdfefd 100644
--- a/src/wallet/api/CMakeLists.txt
+++ b/src/wallet/api/CMakeLists.txt
@@ -71,10 +71,13 @@ target_link_libraries(wallet_api
mnemonics
${LMDB_LIBRARY}
${Boost_CHRONO_LIBRARY}
+ ${Boost_LOCALE_LIBRARY}
+ ${ICU_LIBRARIES}
${Boost_SERIALIZATION_LIBRARY}
${Boost_FILESYSTEM_LIBRARY}
${Boost_SYSTEM_LIBRARY}
${Boost_THREAD_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
${Boost_REGEX_LIBRARY}
PRIVATE
${EXTRA_LIBRARIES})