aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-01-07 19:23:57 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-01-16 08:59:15 +0000
commit693c1908815d8574a1125288f0400eab5f5085a7 (patch)
tree1a93cdf9aaa7cddfcb5241214db82c6c4a1f92c0 /src/wallet/CMakeLists.txt
parentwallet2: reuse fake outs when adjusting fee on transfer (diff)
downloadmonero-693c1908815d8574a1125288f0400eab5f5085a7.tar.xz
wallet: add a node RPC cache layer for simple RPC calls
Mostly getinfo and get_hard_fork_info, which are called pretty often. This speeds up transfers as a bonus.
Diffstat (limited to 'src/wallet/CMakeLists.txt')
-rw-r--r--src/wallet/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index 53b0a794f..922464a3c 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -34,6 +34,7 @@ set(wallet_sources
password_container.cpp
wallet2.cpp
wallet_args.cpp
+ node_rpc_proxy.cpp
api/wallet.cpp
api/wallet_manager.cpp
api/transaction_info.cpp
@@ -55,6 +56,7 @@ set(wallet_private_headers
wallet_rpc_server.h
wallet_rpc_server_commands_defs.h
wallet_rpc_server_error_codes.h
+ node_rpc_proxy.h
api/wallet.h
api/wallet_manager.h
api/transaction_info.h