aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
authorLee Clagett <code@leeclagett.com>2016-11-08 22:55:41 -0500
committerLee Clagett <code@leeclagett.com>2016-11-10 16:39:27 -0500
commit358e068e878892eb3cc0f333215708390e51f0c3 (patch)
tree6fda7493c79996da048bac8f969574e4715c4ced /src/wallet/CMakeLists.txt
parentMerge pull request #1312 (diff)
downloadmonero-358e068e878892eb3cc0f333215708390e51f0c3.tar.xz
Created monero-wallet-rpc, moving functionality from monero-wallet-cli
Diffstat (limited to 'src/wallet/CMakeLists.txt')
-rw-r--r--src/wallet/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index 4f82b3c82..e287d9927 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -31,7 +31,9 @@
set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
set(wallet_sources
+ password_container.cpp
wallet2.cpp
+ wallet_args.cpp
wallet_rpc_server.cpp
api/wallet.cpp
api/wallet_manager.cpp
@@ -45,7 +47,9 @@ set(wallet_api_headers
set(wallet_private_headers
+ password_container.h
wallet2.h
+ wallet_args.h
wallet_errors.h
wallet_rpc_server.h
wallet_rpc_server_commands_defs.h
@@ -77,6 +81,41 @@ target_link_libraries(wallet
PRIVATE
${EXTRA_LIBRARIES})
+set(wallet_rpc_sources
+ wallet_rpc_server.cpp)
+
+set(wallet_rpc_headers)
+
+set(wallet_rpc_private_headers
+ wallet_rpc_server.h)
+
+monero_private_headers(wallet_rpc_server
+ ${wallet_rpc_private_headers})
+monero_add_executable(wallet_rpc_server
+ ${wallet_rpc_sources}
+ ${wallet_rpc_headers}
+ ${wallet_rpc_private_headers})
+
+target_link_libraries(wallet_rpc_server
+ PRIVATE
+ wallet
+ rpc
+ cryptonote_core
+ crypto
+ common
+ ${Boost_CHRONO_LIBRARY}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_FILESYSTEM_LIBRARY}
+ ${Boost_THREAD_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+add_dependencies(wallet_rpc_server version)
+set_property(TARGET wallet_rpc_server
+ PROPERTY
+ OUTPUT_NAME "monero-wallet-rpc")
+install(TARGETS wallet_rpc_server DESTINATION bin)
+
+
# build and install libwallet_merged only if we building for GUI
if (BUILD_GUI_DEPS)
set(libs_to_merge wallet cryptonote_core mnemonics common crypto ringct)