aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2016-03-16 19:49:48 +0200
committerRiccardo Spagni <ric@spagni.net>2016-03-16 19:49:48 +0200
commit4d34682883f325f1a8cffb18089c1278e4f93889 (patch)
tree00763bb73a74267d7c47c120872696642e0ed9d7 /src/wallet/CMakeLists.txt
parentMerge pull request #729 (diff)
parentfixed "undefined reference" for boost::system library (diff)
downloadmonero-4d34682883f325f1a8cffb18089c1278e4f93889.tar.xz
Merge pull request #728
7df2baf fixed "undefined reference" for boost::system library (Ilya Kitaev) 62606f1 Wallet::store_to(path, password) implemented; (Ilya Kitaev) 19fcc74 Wallet::address implemented (Ilya Kitaev) 180ac6e WalletManager::recoveryWallet implemented (Ilya Kitaev) 5a4f099 Wallet::setPassword() method for wallet2_api (Ilya Kitaev) 57d7ffc changes in wallet2_api + implemented WalletManager::openWallet (Ilya Kitaev) f1f9279 get_seed() included to interface (Ilya Kitaev) 930bed7 tests for wallet2_api (Ilya Kitaev) 318660d wallet2 public api. initial commit (Ilya Kitaev)
Diffstat (limited to 'src/wallet/CMakeLists.txt')
-rw-r--r--src/wallet/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index e000c582d..a6fc37dec 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -26,9 +26,13 @@
# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
+
set(wallet_sources
wallet2.cpp
- wallet_rpc_server.cpp)
+ wallet_rpc_server.cpp
+ wallet2_api.cpp)
set(wallet_headers)
@@ -37,7 +41,8 @@ set(wallet_private_headers
wallet_errors.h
wallet_rpc_server.h
wallet_rpc_server_commands_defs.h
- wallet_rpc_server_error_codes.h)
+ wallet_rpc_server_error_codes.h
+ wallet2_api.h)
bitmonero_private_headers(wallet
${wallet_private_headers})
@@ -53,4 +58,6 @@ target_link_libraries(wallet
${Boost_SERIALIZATION_LIBRARY}
${Boost_SYSTEM_LIBRARY}
${Boost_THREAD_LIBRARY}
+ ${Boost_REGEX_LIBRARY}
${EXTRA_LIBRARIES})
+