aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2017-11-25 19:53:34 +0200
committerRiccardo Spagni <ric@spagni.net>2017-11-25 19:53:35 +0200
commit2e54e7ff0b10d262eb95b6f0124ccd8d621af7b7 (patch)
tree72539cbffe8c09acf4c1041229f36a0793e70a99 /src/wallet/CMakeLists.txt
parentMerge pull request #2823 (diff)
parentsplit wallet and wallet_api (diff)
downloadmonero-2e54e7ff0b10d262eb95b6f0124ccd8d621af7b7.tar.xz
Merge pull request #2824
51895fd7 split wallet and wallet_api (moneromooo-monero)
Diffstat (limited to 'src/wallet/CMakeLists.txt')
-rw-r--r--src/wallet/CMakeLists.txt33
1 files changed, 4 insertions, 29 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index e5c79a447..74992139d 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -33,21 +33,7 @@ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
set(wallet_sources
wallet2.cpp
wallet_args.cpp
- node_rpc_proxy.cpp
- api/wallet.cpp
- api/wallet_manager.cpp
- api/transaction_info.cpp
- api/transaction_history.cpp
- api/pending_transaction.cpp
- api/utils.cpp
- api/address_book.cpp
- api/subaddress.cpp
- api/subaddress_account.cpp
- api/unsigned_transaction.cpp)
-
-set(wallet_api_headers
- wallet2_api.h)
-
+ node_rpc_proxy.cpp)
set(wallet_private_headers
wallet2.h
@@ -56,23 +42,12 @@ set(wallet_private_headers
wallet_rpc_server.h
wallet_rpc_server_commands_defs.h
wallet_rpc_server_error_codes.h
- node_rpc_proxy.h
- api/wallet.h
- api/wallet_manager.h
- api/transaction_info.h
- api/transaction_history.h
- api/pending_transaction.h
- api/common_defines.h
- api/address_book.h
- api/subaddress.h
- api/subaddress_account.h
- api/unsigned_transaction.h)
+ node_rpc_proxy.h)
monero_private_headers(wallet
${wallet_private_headers})
monero_add_library(wallet
${wallet_sources}
- ${wallet_api_headers}
${wallet_private_headers})
target_link_libraries(wallet
PUBLIC
@@ -127,6 +102,7 @@ install(TARGETS wallet_rpc_server DESTINATION bin)
# build and install libwallet_merged only if we building for GUI
if (BUILD_GUI_DEPS)
set(libs_to_merge
+ wallet_api
wallet
cryptonote_core
cryptonote_basic
@@ -149,6 +125,5 @@ if (BUILD_GUI_DEPS)
install(TARGETS wallet_merged
ARCHIVE DESTINATION ${lib_folder})
- install(FILES ${wallet_api_headers}
- DESTINATION include/wallet)
+ add_subdirectory(api)
endif()