aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
authorIlya Kitaev <mbg033@gmail.com>2016-04-20 13:01:00 +0300
committerIlya Kitaev <mbg033@gmail.com>2016-04-20 13:01:00 +0300
commitf83f3cbd9647b679e5c9460970b99bd2e9141858 (patch)
tree6ddcaa6888d221b98ecd0450f4b0a39428006b7a /src/wallet/CMakeLists.txt
parentTransactionInfo / TransactionHistory APIs design (diff)
downloadmonero-f83f3cbd9647b679e5c9460970b99bd2e9141858.tar.xz
api implementation splitted over separate files
Diffstat (limited to 'src/wallet/CMakeLists.txt')
-rw-r--r--src/wallet/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index a6fc37dec..33af4f30d 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -32,17 +32,27 @@ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
set(wallet_sources
wallet2.cpp
wallet_rpc_server.cpp
- wallet2_api.cpp)
+ api/wallet.cpp
+ api/wallet_manager.cpp
+ api/transaction_info.cpp
+ api/transaction_history.cpp
+ api/pending_transaction.cpp)
set(wallet_headers)
set(wallet_private_headers
wallet2.h
+ wallet2_api.h
wallet_errors.h
wallet_rpc_server.h
wallet_rpc_server_commands_defs.h
wallet_rpc_server_error_codes.h
- wallet2_api.h)
+ api/wallet.h
+ api/wallet_manager.h
+ api/transaction_info.h
+ api/transaction_history.h
+ api/pending_transaction.h
+ api/common_defines.h)
bitmonero_private_headers(wallet
${wallet_private_headers})