aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
authorIlya Kitaev <mbg033@gmail.com>2016-07-04 17:59:53 +0300
committerIlya Kitaev <mbg033@gmail.com>2016-07-18 23:02:47 +0300
commitd27b883b2dab1ad235e3a4dc9c8c9230c5042d95 (patch)
treeef9c1c7e6ec9b4e0de56f26d6d115aa25362c58d /src/wallet/CMakeLists.txt
parentTransaction fee multiplier aka priority integraged (diff)
downloadmonero-d27b883b2dab1ad235e3a4dc9c8c9230c5042d95.tar.xz
hack to successfull linking for MSYS2
Diffstat (limited to '')
-rw-r--r--src/wallet/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index 0b8fe4cb1..7ed1004e2 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -76,11 +76,15 @@ target_link_libraries(wallet
${EXTRA_LIBRARIES})
-set(libs_to_merge wallet cryptonote_core mnemonics common crypto)
+# set(libs_to_merge wallet cryptonote_core mnemonics common crypto ${UNBOUND_LIBRARY} )
+set(libs_to_merge wallet cryptonote_core mnemonics common crypto)
#MERGE_STATIC_LIBS(wallet_merged wallet_merged "${libs_to_merge}")
merge_static_libs(wallet_merged "${libs_to_merge}")
-install(TARGETS wallet_merged
+# hack - repack libunbound into another static lib - there's conflicting object file "random.c.obj"
+merge_static_libs(wallet_merged2 "${UNBOUND_LIBRARY}")
+
+install(TARGETS wallet_merged wallet_merged2
ARCHIVE DESTINATION lib)
install(FILES ${wallet_api_headers}