aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
authorDusan Klinec <dusan.klinec@gmail.com>2018-12-04 22:01:03 +0100
committerDusan Klinec <dusan.klinec@gmail.com>2018-12-18 16:50:19 +0100
commite37154a87902dca1653458d3eecb385d08ed661b (patch)
tree304b8161013408840f2ef8611d9f46d2b8221f8c /src/wallet/CMakeLists.txt
parentMerge pull request #4927 (diff)
downloadmonero-e37154a87902dca1653458d3eecb385d08ed661b.tar.xz
build: protobuf dependency fixes, libusb build
- docker protobuf dependencies, cross-compilation - device/trezor protobuf build fixes, try_compile - libusb built under all platforms, used by trezor for direct connect
Diffstat (limited to '')
-rw-r--r--src/wallet/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index 4e3fb1ae5..64e84020e 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -134,6 +134,12 @@ if (BUILD_GUI_DEPS)
endif()
install(TARGETS wallet_merged
ARCHIVE DESTINATION ${lib_folder})
+
+ install(FILES ${TREZOR_DEP_LIBS}
+ DESTINATION ${lib_folder})
+ file(WRITE "trezor_link_flags.txt" ${TREZOR_DEP_LINKER})
+ install(FILES "trezor_link_flags.txt"
+ DESTINATION ${lib_folder})
endif()
add_subdirectory(api)