aboutsummaryrefslogtreecommitdiff
path: root/src/wallet/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-02-18 10:47:25 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-03-16 10:32:29 +0000
commit5f146873c58f39632e26c5edbf2f618cacbd76a5 (patch)
tree934c7eb0e55195c8ab3e19ae606522bf4f5db87c /src/wallet/CMakeLists.txt
parentadd RPC to get a histogram of outputs of a given amount (diff)
downloadmonero-5f146873c58f39632e26c5edbf2f618cacbd76a5.tar.xz
wallet: add shared ring database
This maps key images to rings, so that different forks can reuse the rings by key image. This avoids revealing the real inputs like would happen if two forks spent the same outputs with different rings. This database is meant to be shared with all Monero forks which don't bother making a new chain, putting users' privacy at risk in the process. It is placed in a shared data directory by default ($HOME/.shared-ringdb on UNIX like systems). You may use --shared-ringdb-dir to override this location, and should then do so for all Monero forks for them to share the database.
Diffstat (limited to '')
-rw-r--r--src/wallet/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/wallet/CMakeLists.txt b/src/wallet/CMakeLists.txt
index d82e1dace..a5a4c7f56 100644
--- a/src/wallet/CMakeLists.txt
+++ b/src/wallet/CMakeLists.txt
@@ -33,6 +33,7 @@ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
set(wallet_sources
wallet2.cpp
wallet_args.cpp
+ ringdb.cpp
node_rpc_proxy.cpp)
set(wallet_private_headers
@@ -42,6 +43,7 @@ set(wallet_private_headers
wallet_rpc_server.h
wallet_rpc_server_commands_defs.h
wallet_rpc_server_error_codes.h
+ ringdb.h
node_rpc_proxy.h)
monero_private_headers(wallet
@@ -55,6 +57,7 @@ target_link_libraries(wallet
common
cryptonote_core
mnemonics
+ ${LMDB_LIBRARY}
${Boost_CHRONO_LIBRARY}
${Boost_SERIALIZATION_LIBRARY}
${Boost_FILESYSTEM_LIBRARY}