aboutsummaryrefslogtreecommitdiff
path: root/src/simplewallet/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 11:13:59 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commit89cff7bddc6f76ae7382e92569f9a902b262cc5f (patch)
tree0936a6a629f9fccd325c51851140009d698a98d8 /src/simplewallet/CMakeLists.txt
parentMerge pull request #182 (diff)
downloadmonero-89cff7bddc6f76ae7382e92569f9a902b262cc5f.tar.xz
cmake: put each library into its own directory
This cleans up the CMake code and shows patterns more easily (to be refactored in the next commit).
Diffstat (limited to 'src/simplewallet/CMakeLists.txt')
-rw-r--r--src/simplewallet/CMakeLists.txt70
1 files changed, 70 insertions, 0 deletions
diff --git a/src/simplewallet/CMakeLists.txt b/src/simplewallet/CMakeLists.txt
new file mode 100644
index 000000000..756b8d753
--- /dev/null
+++ b/src/simplewallet/CMakeLists.txt
@@ -0,0 +1,70 @@
+# Copyright (c) 2014, The Monero Project
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification, are
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this list of
+# conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice, this list
+# of conditions and the following disclaimer in the documentation and/or other
+# materials provided with the distribution.
+#
+# 3. Neither the name of the copyright holder nor the names of its contributors may be
+# used to endorse or promote products derived from this software without specific
+# prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set(simplewallet_sources
+ simplewallet.cpp
+ password_container.cpp)
+
+set(simplewallet_headers
+ simplewallet.h
+ password_container.h)
+
+source_group(simplewallet
+ FILES
+ ${simplewallet_sources}
+ ${simplewallet_headers})
+
+add_executable(simplewallet
+ ${simplewallet_sources}
+ ${simplewallet_headers})
+target_link_libraries(simplewallet
+ PRIVATE
+ wallet
+ rpc
+ cryptonote_core
+ crypto
+ common
+ mnemonics
+ ${UNBOUND_LIBRARY}
+ ${UPNP_LIBRARIES}
+ ${Boost_LIBRARIES}
+ ${EXTRA_LIBRARIES})
+add_dependencies(simplewallet
+ version)
+set_property(TARGET simplewallet
+ PROPERTY
+ FOLDER "prog")
+
+if (STATIC)
+ set_property(TARGET simplewallet
+ PROPERTY
+ LINK_SEARCH_START_STATIC 1)
+ set_property(TARGET simplewallet
+ PROPERTY
+ LINK_SEARCH_END_STATIC 1)
+endif ()