aboutsummaryrefslogtreecommitdiff
path: root/src/simplewallet/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 11:21:28 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commitc773f465ca7e691b94394d8c7c682c8eb78e5c25 (patch)
tree608ab12a156706ef1c876a33614f3ac6b400d6c3 /src/simplewallet/CMakeLists.txt
parentcmake: put each library into its own directory (diff)
downloadmonero-c773f465ca7e691b94394d8c7c682c8eb78e5c25.tar.xz
cmake: refactor common code with executables
Diffstat (limited to '')
-rw-r--r--src/simplewallet/CMakeLists.txt19
1 files changed, 1 insertions, 18 deletions
diff --git a/src/simplewallet/CMakeLists.txt b/src/simplewallet/CMakeLists.txt
index 756b8d753..310efc2f1 100644
--- a/src/simplewallet/CMakeLists.txt
+++ b/src/simplewallet/CMakeLists.txt
@@ -34,12 +34,7 @@ set(simplewallet_headers
simplewallet.h
password_container.h)
-source_group(simplewallet
- FILES
- ${simplewallet_sources}
- ${simplewallet_headers})
-
-add_executable(simplewallet
+bitmonero_add_executable(simplewallet
${simplewallet_sources}
${simplewallet_headers})
target_link_libraries(simplewallet
@@ -56,15 +51,3 @@ target_link_libraries(simplewallet
${EXTRA_LIBRARIES})
add_dependencies(simplewallet
version)
-set_property(TARGET simplewallet
- PROPERTY
- FOLDER "prog")
-
-if (STATIC)
- set_property(TARGET simplewallet
- PROPERTY
- LINK_SEARCH_START_STATIC 1)
- set_property(TARGET simplewallet
- PROPERTY
- LINK_SEARCH_END_STATIC 1)
-endif ()